Xilinx-lwIP Debug

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Xilinx-lwIP Debug

S Mahadevappa,
	Electrical & Electronic Engineering

Dear All,

I just want enable the lwip-debug in xilinx ".mss file" but system stops at
some random system address. Is anybody familiar with this,

Best Regards Shiv.

===========================================================
Shivakanth Mahadevappa

University of Bristol
Wireless and Networks Research Laboratories,
Merchant Venturers Building,Woodland Road,Bristol,BS8 1UB

Mobile: 07868656963
Fax   : 0117 95 45206
Ph.No : 0117 33 15059/15066
E-mail: [hidden email]
===========================================================


_______________________________________________
lwip-users mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/lwip-users
Reply | Threaded
Open this post in threaded view
|

RE: Xilinx-lwIP Debug

Matthew Yingling
----Original Message----
From: lwip-users-bounces+matt=[hidden email]
[mailto:lwip-users-bounces+matt=[hidden email]]On Behalf Of S
Mahadevappa,Electrical & Electronic Engineering
Sent: Monday, April 23, 2007 7:47 AM
To: [hidden email]
Subject: [lwip-users] Xilinx-lwIP Debug

> Dear All,
>
> I just want enable the lwip-debug in xilinx ".mss file" but system
> stops at some random system address. Is anybody familiar with this,
>
> Best Regards Shiv.
>
> ===========================================================
> Shivakanth Mahadevappa
>
> University of Bristol
> Wireless and Networks Research Laboratories,
> Merchant Venturers Building,Woodland Road,Bristol,BS8 1UB
>
> Mobile: 07868656963
> Fax   : 0117 95 45206
> Ph.No : 0117 33 15059/15066
> E-mail: [hidden email]
> ===========================================================
>
>

I don't if this will help, but I've found that the default debug function
(xil_printf()) cannot handle certain identifiers used by LWIP (like %p) (I
have no idea why Xilinx would set the debug for LwIP to xil_printf()).
Changing it to the larger printf() fixes this.  If it does help, you might
want to report it to Xilinx, since xil_printf() shouldn't crash your
program.

Matthew



_______________________________________________
lwip-users mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/lwip-users
Reply | Threaded
Open this post in threaded view
|

RE: Xilinx-lwIP Debug

Matthew Yingling
In reply to this post by S Mahadevappa, Electrical & Electronic Engineering
----Original Message----
From: lwip-users-bounces+matt=[hidden email]
[mailto:lwip-users-bounces+matt=[hidden email]]On Behalf Of S
Mahadevappa,Electrical & Electronic Engineering
Sent: Monday, April 23, 2007 7:47 AM
To: [hidden email]
Subject: [lwip-users] Xilinx-lwIP Debug

> Dear All,
>
> I just want enable the lwip-debug in xilinx ".mss file" but system
> stops at some random system address. Is anybody familiar with this,
>
> Best Regards Shiv.
>
> ===========================================================
> Shivakanth Mahadevappa
>
> University of Bristol
> Wireless and Networks Research Laboratories,
> Merchant Venturers Building,Woodland Road,Bristol,BS8 1UB
>
> Mobile: 07868656963
> Fax   : 0117 95 45206
> Ph.No : 0117 33 15059/15066
> E-mail: [hidden email]
> ===========================================================
>
>

I don't if this will help, but I've found that the default debug function
(xil_printf()) cannot handle certain identifiers used by LWIP (like %p) (I
have no idea why Xilinx would set the debug for LwIP to xil_printf()).
Changing it to the larger printf() fixes this.  If it does help, you might
want to report it to Xilinx, since xil_printf() shouldn't crash your
program.

Matthew



_______________________________________________
lwip-users mailing list
[hidden email]
http://lists.nongnu.org/mailman/listinfo/lwip-users