[bug #55171] Binding UDP PCB with different IP type PCBs does not work

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #55171] Binding UDP PCB with different IP type PCBs does not work

Jasper Verschueren
URL:
  <https://savannah.nongnu.org/bugs/?55171>

                 Summary: Binding UDP PCB with different IP type PCBs does not
work
                 Project: lwIP - A Lightweight TCP/IP stack
            Submitted by: dziegel
            Submitted on: Thu 06 Dec 2018 01:39:55 PM UTC
                Category: UDP
                Severity: 3 - Normal
              Item Group: None
                  Status: None
                 Privacy: Public
             Assigned to: dziegel
             Open/Closed: Open
         Discussion Lock: Any
         Planned Release: None
            lwIP version: git head

    _______________________________________________________

Details:

reported by Email from Stian Skjelstad:

Hi

I just updated my code to the recent master, and this commit breaks my code:

I have two UDP sockets listening at the same port. One a IPv4 only PCB, and
when trying to listen with an IPv6 only PCB at the same port, it fails.

from udp.c after this commit:
    for (ipcb = udp_pcbs; ipcb != NULL; ipcb = ipcb->next) {
...
          if ((ipcb->local_port == port) &&
              (ip_addr_cmp(&ipcb->local_ip, ipaddr) || ip_addr_isany(ipaddr)
||
              ip_addr_isany(&ipcb->local_ip)))
            return ERR_USE;
....


ip_addr_isany should be IP_IS_ANY_TYPE_VAL instead, so that it only hits
dual-stack listeners?




    _______________________________________________________

Reply to this item at:

  <https://savannah.nongnu.org/bugs/?55171>

_______________________________________________
  Message sent via Savannah
  https://savannah.nongnu.org/


_______________________________________________
lwip-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-devel
Reply | Threaded
Open this post in threaded view
|

[bug #55171] Binding UDP PCB with different IP type PCBs does not work

Jasper Verschueren
Update of bug #55171 (project lwip):

                  Status:                    None => Fixed                  
             Open/Closed:                    Open => Closed                

    _______________________________________________________

Follow-up Comment #1:

Fixed in 2ff0db9a9b047d1c94ddbeea010561d1b9032101

    _______________________________________________________

Reply to this item at:

  <https://savannah.nongnu.org/bugs/?55171>

_______________________________________________
  Message sent via Savannah
  https://savannah.nongnu.org/


_______________________________________________
lwip-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-devel