[bug #56281] arp header process modify back to previous version in etharp_input

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[bug #56281] arp header process modify back to previous version in etharp_input

Wilfred
URL:
  <https://savannah.nongnu.org/bugs/?56281>

                 Summary: arp header process modify back to previous version
in etharp_input
                 Project: lwIP - A Lightweight TCP/IP stack
            Submitted by: koszsim
            Submitted on: Tue 07 May 2019 10:56:54 AM UTC
                Category: ARP
                Severity: 3 - Normal
              Item Group: Faulty Behaviour
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any
         Planned Release: None
            lwIP version: 2.0.3

    _______________________________________________________

Details:

I just wanted to tell how I "fixed" the receiveing of ARP packet in my
application. I am quiet starter with lwIP so probably I did something badly
when I called etharp_input(). Does anybody can help me to figure out the
reason?

I upgraded lwIP from 1.4.1 to 2.0.3. When I finally could build the code and
download the program to the target I noticed that it does not respond to ping
command. Having debugged the program and compared the code with 1.4.1, I could
fix the problem with modifying the code in etharp_input function:

I wrote this statement in line 650 in src/core/ipv4/etharp.c:
hdr = (struct etharp_hdr *)((u8_t*)p->payload + SIZEOF_ETH_HDR);
instead of this statement:
hdr = (struct etharp_hdr *)p->payload;

Now my program works well in my target.

Thank you if someone try to figure out the possible reason.





    _______________________________________________________

Reply to this item at:

  <https://savannah.nongnu.org/bugs/?56281>

_______________________________________________
  Message sent via Savannah
  https://savannah.nongnu.org/


_______________________________________________
lwip-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-devel
Reply | Threaded
Open this post in threaded view
|

Re: [bug #56281] arp header process modify back to previous version in etharp_input

Stian Skjelstad
You probably want to use ethernet_input () instead of etharp_input() when setting up your device with netif_add()

  
Stian Skjelstad


On Tue, May 7, 2019 at 12:57 PM Simon Kószó <[hidden email]> wrote:
URL:
  <https://savannah.nongnu.org/bugs/?56281>

                 Summary: arp header process modify back to previous version
in etharp_input
                 Project: lwIP - A Lightweight TCP/IP stack
            Submitted by: koszsim
            Submitted on: Tue 07 May 2019 10:56:54 AM UTC
                Category: ARP
                Severity: 3 - Normal
              Item Group: Faulty Behaviour
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any
         Planned Release: None
            lwIP version: 2.0.3

    _______________________________________________________

Details:

I just wanted to tell how I "fixed" the receiveing of ARP packet in my
application. I am quiet starter with lwIP so probably I did something badly
when I called etharp_input(). Does anybody can help me to figure out the
reason?

I upgraded lwIP from 1.4.1 to 2.0.3. When I finally could build the code and
download the program to the target I noticed that it does not respond to ping
command. Having debugged the program and compared the code with 1.4.1, I could
fix the problem with modifying the code in etharp_input function:

I wrote this statement in line 650 in src/core/ipv4/etharp.c:
hdr = (struct etharp_hdr *)((u8_t*)p->payload + SIZEOF_ETH_HDR);
instead of this statement:
hdr = (struct etharp_hdr *)p->payload;

Now my program works well in my target.

Thank you if someone try to figure out the possible reason.





    _______________________________________________________

Reply to this item at:

  <https://savannah.nongnu.org/bugs/?56281>

_______________________________________________
  Message sent via Savannah
  https://savannah.nongnu.org/


_______________________________________________
lwip-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-devel

_______________________________________________
lwip-devel mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-devel