lwIP 1.4.1 + FreeRTOS

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

lwIP 1.4.1 + FreeRTOS

Hagen Schmidtchen
Dear lwIP users,

I am currently trying to integrate a simple tcpip lwIP thread into my working FreeRTOS 8.0.1 system running on a CM3 based hardware(Olimex stm32f107).

The problem is that the usual approach of just modifying a working demo seems not to be possible since I could not find a simple
project combining FreeRTOS 8.0.1 and lwIP 1.4.1.
I tried to more or less start from scratch and followed the lwIP wikia steps for integrating lwIP into a running OS.
Creating sys_arch.c and cc.h was no big deal but now Im left with the initialization of a simple tcpip thread in the FreeRTOS environment.

Can anyone please give me a step by step instruction how to do this?
The wikia article about this is more or less useless because it is taken out of centext and therefore only a help for somebody who already did it before.

Thx in advance,
Hagen


_______________________________________________
lwip-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-users
Reply | Threaded
Open this post in threaded view
|

Re: lwIP 1.4.1 + FreeRTOS

davidgrohl
Hi, if you want, I have a working project (freertos + lwip) that run on a stm32f107 equiped board. I don't remember the version.
On monday I'll upload it on dropbox And I will send you The link.
Reply | Threaded
Open this post in threaded view
|

Re: lwIP 1.4.1 + FreeRTOS

oscargomezf
Hi David, I trying to find something similar. I need an example of a project (freertos + lwip) that run on a stm32f107. I need to start a new project and I would like to check if with a stm32f107 is fast enough to my project. Could you send me a link with the example? Do you remember what evaluation board is running the example? Thank you so much. Best regards.
Reply | Threaded
Open this post in threaded view
|

Re: lwIP 1.4.1 + FreeRTOS

oscargomezf
This post was updated on .
In reply to this post by Hagen Schmidtchen
Hi Hagen,

I've got the same problem. Do you find an example with FreeRTOS, STM32F107 and lwIP 1.4.1?

Thank you so much. Best regards.
Reply | Threaded
Open this post in threaded view
|

Re: lwIP 1.4.1 + FreeRTOS

goldsimon@gmx.de
Oscar, (or whatever your name is), after reading this twice: please
register with the mailing list on savannah instead of writing via nabble
so I don't have to manually accept all your (duplicate) mails.

Thanks,
Simon


oscargomezf wrote:

> Hi,
>
> I¡ve got the same problem. Doy you find an example with FreeRTOS, STM32F107
> and lwIP 1.4.1?
>
> Thank you so much. Best regards.
>
>
>
> --
> View this message in context: http://lwip.100.n7.nabble.com/lwIP-1-4-1-FreeRTOS-tp22998p24050.html
> Sent from the lwip-users mailing list archive at Nabble.com.
>
> _______________________________________________
> lwip-users mailing list
> [hidden email]
> https://lists.nongnu.org/mailman/listinfo/lwip-users


_______________________________________________
lwip-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-users