memp_malloc: out of memory in pool TCPIP_MSG_INPKT

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

memp_malloc: out of memory in pool TCPIP_MSG_INPKT

Reaster
Hi everyone,
I have got a problem with lwIP memp allocation. First my HW/SW
configuration:
CC1312R (ARM Cortex M4F) - TI Launchpad Board,
lwIP 2.0.3 in operation system mode (TI-RTOS),
ENC28J60 MAC+PHY.

Generally stack is working, I'm able to ping my board with success, board is
getting IP adress from DHCP succesfully, now I want to move forward but
first I want to resolve some stability problems.
I can't afford one problem which I described also in the topic: out of
memory in pool TCPIP_MSG_INPKT.

I've printed stats for this pool just after assertion:
MEM TCPIP_MSG_INPKT
        avail: 10
        used: 1
        max: 2
        err: 1

And after few minutes of working:
MEM TCPIP_MSG_INPKT
        avail: 10
        used: 1
        max: 2
        err: 60

I tried to set number of MEMP_NUM_TCPIP_MSG_INPKT to 500 but that didn't
change anything.

MEM TCPIP_MSG_INPKT
        avail: 500
        used: 1
        max: 1
        err: 1

I went through memp_init pool by pool and everything seemed to be ok.
Generally the problem exists before do_memp_malloc_pool_fn (where the
assertion raises), I can observe problem in memp_malloc_fn,
memp_pools[type]->tab is NULL there.

Did you see similiar problem? I appreciate for any help.

Regards,
Paweł




--
Sent from: http://lwip.100.n7.nabble.com/lwip-users-f3.html

_______________________________________________
lwip-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-users
Reply | Threaded
Open this post in threaded view
|

Re: memp_malloc: out of memory in pool TCPIP_MSG_INPKT

Reaster
Hi,
I've found solution for my problem.
I made a mistake in Mailbox regarded function and had a memory corruption. Now everything is ok.

Regards,
Paweł

niedz., 19 sie 2018 o 14:38 Reaster <[hidden email]> napisał(a):
Hi everyone,
I have got a problem with lwIP memp allocation. First my HW/SW
configuration:
CC1312R (ARM Cortex M4F) - TI Launchpad Board,
lwIP 2.0.3 in operation system mode (TI-RTOS),
ENC28J60 MAC+PHY.

Generally stack is working, I'm able to ping my board with success, board is
getting IP adress from DHCP succesfully, now I want to move forward but
first I want to resolve some stability problems.
I can't afford one problem which I described also in the topic: out of
memory in pool TCPIP_MSG_INPKT.

I've printed stats for this pool just after assertion:
MEM TCPIP_MSG_INPKT
        avail: 10
        used: 1
        max: 2
        err: 1

And after few minutes of working:
MEM TCPIP_MSG_INPKT
        avail: 10
        used: 1
        max: 2
        err: 60

I tried to set number of MEMP_NUM_TCPIP_MSG_INPKT to 500 but that didn't
change anything.

MEM TCPIP_MSG_INPKT
        avail: 500
        used: 1
        max: 1
        err: 1

I went through memp_init pool by pool and everything seemed to be ok.
Generally the problem exists before do_memp_malloc_pool_fn (where the
assertion raises), I can observe problem in memp_malloc_fn,
memp_pools[type]->tab is NULL there.

Did you see similiar problem? I appreciate for any help.

Regards,
Paweł




--
Sent from: http://lwip.100.n7.nabble.com/lwip-users-f3.html

_______________________________________________
lwip-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-users

_______________________________________________
lwip-users mailing list
[hidden email]
https://lists.nongnu.org/mailman/listinfo/lwip-users